<!DOCTYPE html>
<!--[if lt IE 7]>
<html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>
<html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>
<html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!-->
<html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<title>25 Cleveland Fish Fries You Need To Try This Lenten Season</title>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://photos.clevescene.com/xmlrpc.php">

<link rel="shortcut icon" href="https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/favicon.clevescene.ico">

<style type="text/css">
		a,
		div#HeaderforCategoryorSection h1,
		.jThumbnailScroller .jTscrollerNextButton:hover,
		.jThumbnailScroller .jTscrollerPrevButton:hover,
		.jThumbnailScroller .jTscroller a:hover,
		.footerCustomLogin ul li a,
		.footerCustomNav ul li a,
		.back-to-slider a:hover,
		.navbar-default .navbar-toggle:focus,
		.navbar-default .navbar-toggle:hover,
		.gallery-item h2 a,
		.categories a {
			color: #EE1C25;
		}

		.slide-nav span,
		#crumbs,
		.page-navigation, .wp-prev-next {
			background: #EE1C25;
		}

		.gallery-item h2 a:hover,
		.categories a:hover {
			color: #FF000B;
		}

		.bones_page_navi li a:hover,
		.bones_page_navi li a:focus,
		.bones_page_navi li.bpn-current,
		.bones_page_navi li.bpn-prev-link a:hover,
		.bones_page_navi li.bpn-next-link a:hover,
		.bones_page_navi li.bpn-first-page-link a:hover,
		.bones_page_navi li.bpn-last-page-link a:hover {
			background: #FF000B;
		}

		.navbar-default .navbar-toggle:focus,
		.navbar-default .navbar-toggle:hover {
			background: #EE1C25 !important;;
		}

		.slide-nav span:hover {
			background: #FF000B;
		}

		@media (max-width: 600px) {
			.main-navigation {
				background: #EE1C25;
			}
		}
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            background-color: #000000 !important;
            border-color: #000000 !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            background-color: transparent !important;
            border-color: #000000 !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
            color: #000000 !important;
        }
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            color: #ffffff !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            color: #000000 !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #ee1c25 !important;
            border-color: #ee1c25 !important;
        }
        .qc-cmp-small-toggle,
        .qc-cmp-toggle {
            background-color: #C0C0C0 !important;
            border-color: #C0C0C0 !important;
        }
    </style>


<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="25 Cleveland Fish Fries You Need To Try This Lenten Season" />
<meta property="og:description" content="Over the years, many Cleveland restaurants, taverns and pubs have kept their Lenten fish fry traditions afloat, some have even started their own tasty traditions. And with these 20 spots, you&#8217;ll find just the fish and atmosphere you&#8217;re looking for this season." />
<meta property="og:url" content="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/" />
<meta property="og:site_name" content="Galleries | Cleveland Scene" />
<meta property="article:tag" content="Cleveland Fish Fry" />
<meta property="article:tag" content="Fish Fry" />
<meta property="article:tag" content="Lent" />
<meta property="article:section" content="Food and Drink" />
<meta property="article:published_time" content="2019-03-06T13:00:45+00:00" />
<meta property="article:modified_time" content="2020-02-28T13:44:36+00:00" />
<meta property="og:updated_time" content="2020-02-28T13:44:36+00:00" />
<meta property="og:image" content="https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg" />
<meta property="og:image:secure_url" content="https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg" />
<meta property="og:image:width" content="1100" />
<meta property="og:image:height" content="822" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://photos.clevescene.com/#website","url":"https://photos.clevescene.com/","name":"Galleries | Cleveland Scene","inLanguage":"en-US","potentialAction":{"@type":"SearchAction","target":"https://photos.clevescene.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/#primaryimage","inLanguage":"en-US","url":"https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg","width":1100,"height":822},{"@type":"WebPage","@id":"https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/#webpage","url":"https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/","name":"25 Cleveland Fish Fries You Need To Try This Lenten Season","isPartOf":{"@id":"https://photos.clevescene.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/#primaryimage"},"datePublished":"2019-03-06T13:00:45+00:00","dateModified":"2020-02-28T13:44:36+00:00","author":{"@id":"https://photos.clevescene.com/#/schema/person/95f97d329d06fc50405dd3d4c78b6fc2"}},{"@type":["Person"],"@id":"https://photos.clevescene.com/#/schema/person/95f97d329d06fc50405dd3d4c78b6fc2","name":"Scene Intern","image":{"@type":"ImageObject","@id":"https://photos.clevescene.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a3ef39ccb4373ee9784fc50945d25bf8?s=96&d=mm&r=g","caption":"Scene Intern"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Galleries | Cleveland Scene &raquo; Feed" href="https://photos.clevescene.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Galleries | Cleveland Scene &raquo; Comments Feed" href="https://photos.clevescene.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/photos.clevescene.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='socialite-css-css' href='https://photos.clevescene.com/wp-content/plugins/wpsocialite/lib/wpsocialite.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://photos.clevescene.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpba_front_end_styles-css' href='https://photos.clevescene.com/wp-content/plugins/wp-better-attachments/assets/css/wpba-frontend.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-style-css' href='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/css/bootstrap.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-theme-style-css' href='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/css/bootstrap-theme.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-style-css' href='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/css/font-awesome.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='montserrat-css' href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='lato-css' href='//fonts.googleapis.com/css?family=Lato%3A400italic%2C400%2C700%2C700italic&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='main-style-css' href='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/css/main.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-basic-style-css' href='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='slider-css-css' href='https://photos.clevescene.com/wp-content/plugins/photo-slider-new/css/slider.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript' src='https://photos.clevescene.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/js/vendor/modernizr.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/js/vendor/respond.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/js/vendor/html5shiv.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://photos.clevescene.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://photos.clevescene.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://photos.clevescene.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://photos.clevescene.com/?p=77958' />
<link rel="alternate" type="application/json+oembed" href="https://photos.clevescene.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphotos.clevescene.com%2F20-cleveland-fish-fries-need-try-lenten-season%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://photos.clevescene.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphotos.clevescene.com%2F20-cleveland-fish-fries-need-try-lenten-season%2F&#038;format=xml" />

<script async='async' src='//securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
	</script>
<script>
		googletag.cmd.push( function () {
			DesktopInterstitial = googletag.defineOutOfPageSlot('/43707298/CLE_DesktopInterstitial', 'div-gpt-ad-cle_desktopinterstitial').setTargeting('media', ['screen']).setTargeting('oop', ['desktop-interstitial']).addService(googletag.pubads());DesktopNativeEndOfArticle = googletag.defineOutOfPageSlot('/43707298/CLE_DesktopNative', 'div-gpt-ad-cle_desktopnative-3').setTargeting('media', ['screen']).setTargeting('oop', ['native-EndOfArticle']).addService(googletag.pubads());Top = googletag.defineSlot('/43707298/CLE_728x90', [728, 90], 'div-gpt-ad-cle_728x90-1').setTargeting('media', ['screen']).setTargeting('placement', ['ATF']).addService(googletag.pubads());setInterval( function() {if ( jQuery("#div-gpt-ad-cle_728x90-1").length > 0 ) {googletag.pubads().refresh([Top, Middle] );}}, 10000 );Top3 = googletag.defineSlot('/43707298/CLE_970x90', [[970, 90], [970, 250]], 'div-gpt-ad-cle_970x90').setTargeting('media', ['screen']).setTargeting('placement', ['ATF']).addService(googletag.pubads());setInterval( function() {if ( jQuery("#div-gpt-ad-cle_970x90").length > 0 ) {googletag.pubads().refresh([Top3] );}}, 20000 );Middle = googletag.defineSlot('/43707298/CLE_300x250', [300, 250], 'div-gpt-ad-cle_300x250-1').setTargeting('media', ['screen']).setTargeting('placement', ['ATF']).addService(googletag.pubads());Middle1 = googletag.defineSlot('/43707298/CLE_300x250', [[300, 250], [300, 600]], 'div-gpt-ad-cle_300x250-2').setTargeting('media', ['screen']).setTargeting('placement', ['BTF']).addService(googletag.pubads());Middle1A = googletag.defineSlot('/43707298/CLE_300x250', [300, 250], 'div-gpt-ad-cle_300x250-4').setTargeting('media', ['screen']).setTargeting('placement', ['BTF']).addService(googletag.pubads());Bottom = googletag.defineSlot('/43707298/CLE_728x90', [728, 90], 'div-gpt-ad-cle_728x90-2').setTargeting('media', ['screen']).setTargeting('placement', ['BTF']).addService(googletag.pubads());Position1 = googletag.defineSlot('/43707298/CLE_300x250', [300, 250], 'div-gpt-ad-cle_300x250-3').setTargeting('media', ['screen']).setTargeting('placement', ['Slideshowinline']).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.pubads().collapseEmptyDivs();googletag.pubads().setTargeting( 'template', [ 'slideshow' ] ).setTargeting( 'oid', [] );googletag.pubads().setTargeting('vertical', ['food']).setTargeting( 'category', [] );googletag.enableServices();		} );

	</script>
<script src="//connect.facebook.net/en_US/all.js#appId=282729121836019&amp;xfbml=1" type='text/javascript'>
	</script>
 
<script>
		(function ( i, s, o, g, r, a, m ) {
			i[ 'GoogleAnalyticsObject' ] = r;
			i[ r ] = i[ r ] || function () {
					(i[ r ].q = i[ r ].q || []).push( arguments )
				}, i[ r ].l = 1 * new Date();
			a = s.createElement( o ),
				m = s.getElementsByTagName( o )[ 0 ];
			a.async = 1;
			a.src = g;
			m.parentNode.insertBefore( a, m )
		})( window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga' );
		ga( 'create', "UA-5882309-1", 'auto' );
	</script>

<script type='text/javascript'>
		var vertical_name = "food";
		var vertical_title = "slideshow";
		var slide_prefix = "?slide";
		var slide_separator =  "=";
		var slide_name_separator =  "&";
		var slide_title =  "?slide=";
		var gtm_id = "GTM-5LHFPG";
		var slideshow_ad_position = "div-gpt-ad-cle_300x250-3";
	</script>

<script>(function ( w, d, s, l, i ) {
			w[ l ] = w[ l ] || [];
			w[ l ].push( {
				'gtm.start': new Date().getTime(), event: 'gtm.js'
			} );
			var f = d.getElementsByTagName( s )[ 0 ],
				j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
			j.async = true;
			j.src =
				'//www.googletagmanager.com/gtm.js?id=' + i + dl;
			f.parentNode.insertBefore( j, f );
		})( window, document, 'script', 'dataLayer', gtm_id );</script>

<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style></head>
<body class="post-template-default single single-post postid-77958 single-format-standard">

<noscript>
	<iframe src="//www.googletagmanager.com/ns.html?id=" +gtm_id
	        height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>

<!--[if lt IE 8]>
<p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade
	your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to
	improve your experience.</p>
<![endif]-->
<div class="container page-container">
<header role="banner">
<div class="row row-with-vspace site-branding">
<div class="col-md-4 site-title">
<h1 class="site-title-heading">
<a href="http://www.clevescene.com" title="Cleveland Scene" rel="home">
<img src="https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/img/logo.clevescene.250.png" border="0" alt="Cleveland Scene home page." />
</a>
</h1>
</div>
<div class="col-md-8 page-header-top-right">
<div class="sr-only">
<a href="#content" title="Skip to content">Skip to content</a>
</div>
<div class="pull-right">
<div id="div-gpt-ad-cle_728x90-1"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_728x90-1'); });</script></div> </div>
<div class="clearfix">
</div>
</div>
</div>
<div class="row main-navigation">
<div class="col-md-12">
<nav class="navbar navbar-default" role="navigation">
<div class="navbar-header">
<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-primary-collapse">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a href="http://www.clevescene.com" target="_blank"><img src="https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/img/logo.clevescene.mobile.png" class="mobile-logo"></a>
<h1 class="site-title">Slideshows</h1>
</div>
<div class="collapse navbar-collapse navbar-primary-collapse">
<ul id="menu-main" class="nav navbar-nav"><li id="menu-item-25009" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25009"><a href="http://www.clevescene.com/">Home</a></li>
<li id="menu-item-25010" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25010"><a href="http://www.clevescene.com/cleveland/news/Section?oid=1392923">News</a></li>
<li id="menu-item-25011" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25011"><a href="http://www.clevescene.com/cleveland/music/Section?oid=1392924">Music</a></li>
<li id="menu-item-25012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25012"><a href="http://www.clevescene.com/cleveland/film/Section?oid=1392922">Movies</a></li>
<li id="menu-item-25013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25013"><a href="http://www.clevescene.com/cleveland/dining/Section?oid=1392921">Eat</a></li>
<li id="menu-item-25014" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25014"><a href="http://www.clevescene.com/cleveland/arts/Section?oid=1392919">Arts</a></li>
<li id="menu-item-25015" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25015"><a href="/">Slideshows</a></li>
<li id="menu-item-25016" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25016"><a href="http://www.clevescene.com/cleveland/EventSearch?narrowByDate=Today">Calendar</a></li>
<li id="menu-item-25017" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25017"><a href="http://www.clevescene.com/cleveland/special-sections/Section?oid=1518239">Special Issues</a></li>
<li id="menu-item-25018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25018 dropdown" data-dropdown="dropdown"><a href="https://www.clevescene.com/cleveland/BestOf?oid=6911252" class="dropdown-toggle" data-toggle="dropdown">Best of <span class="caret"></span> </a>
<ul class="sub-menu dropdown-menu">
<li id="menu-item-79766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79766"><a href="http://clevescene.secondstreetapp.com/l/Cleveland-Scenes-Voters-Choice-2018">2018 Readers Poll</a></li>
</ul>
</li>
<li id="menu-item-25019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25019"><a href="http://www.clevescene.com/cleveland/FreeStuff?category=4531976">Giveaways</a></li>
<li id="menu-item-25020" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25020"><a href="http://www.clevescene.com/cleveland/FreeStuff?category=4531979">Scene Events</a></li>
</ul> </div>
</nav>
</div>
</div>
<div class="billboard"><div id="div-gpt-ad-cle_970x90"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_970x90'); });</script></div></div>
</header>
<div id="content" class="row row-with-vspace site-content"><div class="col-md-8 content-area" id="main-column">
<main id="main" class="site-main" role="main">
<h1 class="single-title" itemprop="headline">25 Cleveland Fish Fries You Need To Try This Lenten Season</h1>
<div class="photo-slider-container">
<div id="social_browser">
<div class="social 1" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=1&screen-shot-2018-02-09-at-2-05-21-pm&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=1&screen-shot-2018-02-09-at-2-05-21-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=1&screen-shot-2018-02-09-at-2-05-21-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=1&screen-shot-2018-02-09-at-2-05-21-pm&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 2" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=2&prosperity-4&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=2&prosperity-4" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=2&prosperity-4" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=2&prosperity-4&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 3" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=3&screen-shot-2018-02-09-at-2-34-34-pm&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=3&screen-shot-2018-02-09-at-2-34-34-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=3&screen-shot-2018-02-09-at-2-34-34-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=3&screen-shot-2018-02-09-at-2-34-34-pm&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 4" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=4&screen-shot-2018-02-12-at-1-12-17-pm&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=4&screen-shot-2018-02-12-at-1-12-17-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=4&screen-shot-2018-02-12-at-1-12-17-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=4&screen-shot-2018-02-12-at-1-12-17-pm&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 5" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=5&lake-house-restaurant-pic-from-their-facebook&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=5&lake-house-restaurant-pic-from-their-facebook" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=5&lake-house-restaurant-pic-from-their-facebook" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=5&lake-house-restaurant-pic-from-their-facebook&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 6" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=6&lake-house-restaurant-pic-from-their-facebook&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=6&lake-house-restaurant-pic-from-their-facebook" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=6&lake-house-restaurant-pic-from-their-facebook" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=6&lake-house-restaurant-pic-from-their-facebook&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 7" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=7&tick-tock-from-facebook&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=7&tick-tock-from-facebook" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=7&tick-tock-from-facebook" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=7&tick-tock-from-facebook&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 8" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=8&screen-shot-2018-02-09-at-3-03-33-pm&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=8&screen-shot-2018-02-09-at-3-03-33-pm" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=8&screen-shot-2018-02-09-at-3-03-33-pm" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=8&screen-shot-2018-02-09-at-3-03-33-pm&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 9" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=9&academy-from-scene&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=9&academy-from-scene" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=9&academy-from-scene" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=9&academy-from-scene&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 10" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=10&flat-iron-cafe-from-scene&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=10&flat-iron-cafe-from-scene" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=10&flat-iron-cafe-from-scene" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=10&flat-iron-cafe-from-scene&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 11" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=11&rocky-river-brewing-company&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=11&rocky-river-brewing-company" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=11&rocky-river-brewing-company" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=11&rocky-river-brewing-company&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 12" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=12&club-house-that-i-took&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=12&club-house-that-i-took" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=12&club-house-that-i-took" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=12&club-house-that-i-took&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 13" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=13&the-little-polish-diner&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=13&the-little-polish-diner" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=13&the-little-polish-diner" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=13&the-little-polish-diner&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 14" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=14&1409149162-aroundthecorner_2_&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=14&1409149162-aroundthecorner_2_" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=14&1409149162-aroundthecorner_2_" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=14&1409149162-aroundthecorner_2_&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 15" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=15&gears-and-cheers-from-their-facebook-page&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=15&gears-and-cheers-from-their-facebook-page" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=15&gears-and-cheers-from-their-facebook-page" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=15&gears-and-cheers-from-their-facebook-page&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 16" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=16&gears-and-cheers-from-their-facebook-page&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=16&gears-and-cheers-from-their-facebook-page" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=16&gears-and-cheers-from-their-facebook-page" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=16&gears-and-cheers-from-their-facebook-page&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 17" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=17&dicillo-tavern-fish-fry&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=17&dicillo-tavern-fish-fry" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=17&dicillo-tavern-fish-fry" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=17&dicillo-tavern-fish-fry&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 18" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=18&merwins-3&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=18&merwins-3" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=18&merwins-3" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=18&merwins-3&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 19" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=19&grumpys1-3&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=19&grumpys1-3" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=19&grumpys1-3" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=19&grumpys1-3&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 20" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=20&the-harp-9&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=20&the-harp-9" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=20&the-harp-9" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=20&the-harp-9&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 21" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=21&merry-arts-pub-8&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=21&merry-arts-pub-8" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=21&merry-arts-pub-8" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=21&merry-arts-pub-8&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 22" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=22&hansa&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=22&hansa" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=22&hansa" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=22&hansa&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 23" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=23&georgetown-3&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=23&georgetown-3" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=23&georgetown-3" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=23&georgetown-3&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 24" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=24&fishers-american-tavern&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=24&fishers-american-tavern" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=24&fishers-american-tavern" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=24&fishers-american-tavern&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 25" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=25&carnicero-2&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=25&carnicero-2" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=25&carnicero-2" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=25&carnicero-2&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 26" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=26&carnicero-2&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=26&carnicero-2" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=26&carnicero-2" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=26&carnicero-2&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 27" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=27&thyme&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=27&thyme" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=27&thyme" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=27&thyme&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div><div class="social 28" style="display: none;"><ul class="wpsocialite social-buttons small"><li><a href="http://www.facebook.com/sharer.php?u=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=28&firehouse&amp;locale=en_US&amp;t=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite facebook-like" data-lang="en_US" data-href="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=28&firehouse" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="vhidden">Share on Facebook.</span></a></li><li><a href="http://twitter.com/share" class="socialite twitter-share" data-text="25 Cleveland Fish Fries You Need To Try This Lenten Season" data-url="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=28&firehouse" data-count="horizontal" data-lang="en_US" data-via="" rel="nofollow" target="_blank"><span class="vhidden">Share on Twitter.</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=28&firehouse&amp;media=https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg&amp;description=25 Cleveland Fish Fries You Need To Try This Lenten Season" class="socialite pinterest-pinit" data-count-layout="horizontal"><span class="vhidden">Pin It!</span></a></li></ul></div> </div>
<div class="slide-nav">
<span class="prev">Prev</span>
<div class="photo-progress"></div>
<span class="next">Next</span>
</div>

<div class="photo-slider" itemscope itemtype="http://schema.org/ImageGallery">
<div id="div-gpt-ad-cle_300x250-3_container" style="display: none" class="inline">
<div id="div-gpt-ad-cle_300x250-3"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_300x250-3'); });</script></div> </div>
<img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/uploads/2018/02/Screen-Shot-2018-02-09-at-2.05.21-PM.jpg" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Screen-Shot-2018-02-09-at-2.05.21-PM.jpg" data-postname="screen-shot-2018-02-09-at-2-05-21-pm" data-width="1100" data-height="777" rel="1" title="&lt;h3&gt;&lt;a href=&quot;https://www.sokolowskis.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Sokolowski’s University Inn&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;1201 University Rd., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Get your fish fry fix in at this longstanding Polish institution, where their Friday specials include beer battered cod and yellow lake perch.
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.instagram.com/p/Bdk_VyXHlAZ/?taken-by=thinkbig_drawtiny&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;@thinkbig_drawtiny/Instagram&lt;/a&gt;
" data-title="<span class='post-excerpt'><h3><a href=::https://www.sokolowskis.com:: target=::_blank:: rel=::noopener noreferrer::> Sokolowski’s University Inn</a></h3>
<i>1201 University Rd., Cleveland</i>
<br>
<br> Get your fish fry fix in at this longstanding Polish institution, where their Friday specials include beer battered cod and yellow lake perch.
<br>
<br>Photo via <a href=::https://www.instagram.com/p/Bdk_VyXHlAZ/?taken-by=thinkbig_drawtiny:: target=::_blank:: rel=::noopener noreferrer::>@thinkbig_drawtiny/Instagram</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg" data-url="https://photos.clevescene.com/wp-content/uploads/2017/03/Prosperity.jpg" data-postname="prosperity-4" data-width="1100" data-height="822" rel="2" title="&lt;h3&gt;&lt;a href=&quot;http://prosperitysocialclub.com/&quot;target=&quot;_blank&quot;&gt; Prosperity Social Club&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;1109 Starkweather Ave., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Cozy and retro, this former workingman’s watering hole serves up delicious food, booze, and a bowling machine along with the live music. And they’re also known for serving up one of the best fish frys in town, their ‘Gotta Haddock” plate. It’s $22, but you get a ton of fried haddock, mac and cheese and a lot of cole slaw along with a cup of chowder and two potato pierogies with caramelized onions and a dollop of sour cream. If you don’t need food for a family of four, there’s a cheaper offering that still comes with plenty of haddock, slaw and mac and cheese for $14 every Friday throught Lent.
&lt;br&gt;
&lt;br&gt;Photo via Scene Archives
" data-title="<span class='post-excerpt'><h3><a href=::http://prosperitysocialclub.com/::target=::_blank::> Prosperity Social Club</a></h3>
<i>1109 Starkweather Ave., Cleveland</i>
<br>
<br> Cozy and retro, this former workingman’s watering hole serves up delicious food, booze, and a bowling machine along with the live music. And they’re also known for serving up one of the best fish frys in town, their ‘Gotta Haddock” plate. It’s $22, but you get a ton of fried haddock, mac and cheese and a lot of cole slaw along with a cup of chowder and two potato pierogies with caramelized onions and a dollop of sour cream. If you don’t need food for a family of four, there’s a cheaper offering that still comes with plenty of haddock, slaw and mac and cheese for $14 every Friday throught Lent.
<br>
<br>Photo via Scene Archives
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/uploads/2018/02/Screen-Shot-2018-02-09-at-2.34.34-PM.jpg" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Screen-Shot-2018-02-09-at-2.34.34-PM.jpg" data-postname="screen-shot-2018-02-09-at-2-34-34-pm" data-width="896" data-height="674" rel="3" title="&lt;h3&gt;&lt;a href=&quot;https://www.luchitas.net&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Luchita’s&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;128751 Center Ridge Rd, Westlake&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; This West Side Mexican spot adds a Latin flair to the traditional fish fry. Their beer battered cod is served with chipotle tartar salsa, mac and quest, Mexican street corn and a salad. They serve their fish fry every Friday for lunch and dinner through the end of Lent.
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.instagram.com/p/6i8VEDzh9d/&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;@rnackenzie/Instagram&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::https://www.luchitas.net:: target=::_blank:: rel=::noopener noreferrer::> Luchita’s</a></h3>
<i>128751 Center Ridge Rd, Westlake</i>
<br>
<br> This West Side Mexican spot adds a Latin flair to the traditional fish fry. Their beer battered cod is served with chipotle tartar salsa, mac and quest, Mexican street corn and a salad. They serve their fish fry every Friday for lunch and dinner through the end of Lent.
<br>
<br>Photo via <a href=::https://www.instagram.com/p/6i8VEDzh9d/:: target=::_blank:: rel=::noopener noreferrer::>@rnackenzie/Instagram</a></span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/uploads/2018/02/Screen-Shot-2018-02-12-at-1.12.17-PM.jpg" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Screen-Shot-2018-02-12-at-1.12.17-PM.jpg" data-postname="screen-shot-2018-02-12-at-1-12-17-pm" data-width="904" data-height="622" rel="4" title="&lt;h3&gt;&lt;a href=&quot;https://www.stellamiawestlake.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Stella Mia Ristorante&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;28751 Center Ridge Rd., Westlake&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; This traditional Italian restaurant features a classic fish fry of perch, fries, and cole slaw. They're serving their fry for lunch and dinner.
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.instagram.com/p/BUVTG01gVJ1wNgHx0O-g_4ENtF3anM4tuqgBRQ0/?taken-by=coooney&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;@coooney/Instagram&lt;/a&gt;
" data-title="<span class='post-excerpt'><h3><a href=::https://www.stellamiawestlake.com:: target=::_blank:: rel=::noopener noreferrer::> Stella Mia Ristorante</a></h3>
<i>28751 Center Ridge Rd., Westlake</i>
<br>
<br> This traditional Italian restaurant features a classic fish fry of perch, fries, and cole slaw. They're serving their fry for lunch and dinner.
<br>
<br>Photo via <a href=::https://www.instagram.com/p/BUVTG01gVJ1wNgHx0O-g_4ENtF3anM4tuqgBRQ0/?taken-by=coooney:: target=::_blank:: rel=::noopener noreferrer::>@coooney/Instagram</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Lake-House-Restaurant-pic-from-their-facebook.jpg" data-postname="lake-house-restaurant-pic-from-their-facebook" data-width="720" data-height="540" rel="5" title=" &lt;h3&gt;&lt;a href=&quot;http://www.mylakehouserestaurant.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Lake House Restaurant&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;11850 Edgewater Dr., Lakewood&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Take in the Lake Erie view while enjoying an all-you-can eat fish fry on Wednesdays and Fridays. This $9.99 deal includes fried tilapia served with French fries and coleslaw. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/LakeHouseRestaurant.LAKEWOOD/photos/a.780986835250414.1073741827.233310200018083/1943326532349766/?type=3&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Lake House Restaurant/Facebook&lt;/a&gt;
" data-title="<span class='post-excerpt'> <h3><a href=::http://www.mylakehouserestaurant.com:: target=::_blank:: rel=::noopener noreferrer::> Lake House Restaurant</a></h3>
<i>11850 Edgewater Dr., Lakewood</i>
<br>
<br> Take in the Lake Erie view while enjoying an all-you-can eat fish fry on Wednesdays and Fridays. This $9.99 deal includes fried tilapia served with French fries and coleslaw. 
<br>
<br>Photo via <a href=::https://www.facebook.com/LakeHouseRestaurant.LAKEWOOD/photos/a.780986835250414.1073741827.233310200018083/1943326532349766/?type=3&theater:: target=::_blank:: rel=::noopener noreferrer::>Lake House Restaurant/Facebook</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="6" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/tick-tock-from-facebook.jpg" data-postname="tick-tock-from-facebook" data-width="517" data-height="319" rel="7" title="&lt;h3&gt;&lt;a href=&quot;http://www.ticktockcleveland.com/&quot; target=&quot; _blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Tick Tock Tavern&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt; 11526 Clifton Blvd., 216-631-6111&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;Get fabulous and filthy for this all-you-can eat fish fry for $8.95 every Wednesdays and Fridays, and don’t forget the dirty part. Get $5.50 dirty, filthy martinis for your before, during or after dinner drink. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/117452364946936/photos/a.207225692636269.64491.117452364946936/207227582636080/?type=1&amp;theater/&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Tick Tock Tavern/Facebook&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::http://www.ticktockcleveland.com/:: target=:: _blank:: rel=::noopener noreferrer::>Tick Tock Tavern</a></h3>
<i> 11526 Clifton Blvd., 216-631-6111</i>
<br>
<br>Get fabulous and filthy for this all-you-can eat fish fry for $8.95 every Wednesdays and Fridays, and don’t forget the dirty part. Get $5.50 dirty, filthy martinis for your before, during or after dinner drink. 
<br>
<br>Photo via <a href=::https://www.facebook.com/117452364946936/photos/a.207225692636269.64491.117452364946936/207227582636080/?type=1&theater/:: target=::_blank:: rel=::noopener noreferrer::>Tick Tock Tavern/Facebook</a></span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Screen-Shot-2018-02-09-at-3.03.33-PM.jpg" data-postname="screen-shot-2018-02-09-at-3-03-33-pm" data-width="900" data-height="902" rel="8" title="&lt;h3&gt;&lt;a href=&quot;http://cleatswings.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Cleats Club Seat and Grille&lt;/a&gt;&lt;/h3&gt;
&lt;I&gt;Multiple Locations&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; With multiple locations throughout Northeast Ohio, this sports bar and restaurant has you covered no matter where you are with an all-you-can-eat fish fry special on Fridays.
&lt;br&gt; 
&lt;br&gt;Photo via &lt;a href=&quot;https://www.instagram.com/p/BIjAADPhUHZ/?taken-at=259197237&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;@drock1987/Instagram&lt;/a&gt;
" data-title="<span class='post-excerpt'><h3><a href=::http://cleatswings.com:: target=::_blank:: rel=::noopener noreferrer::> Cleats Club Seat and Grille</a></h3>
<I>Multiple Locations</i>
<br>
<br> With multiple locations throughout Northeast Ohio, this sports bar and restaurant has you covered no matter where you are with an all-you-can-eat fish fry special on Fridays.
<br> 
<br>Photo via <a href=::https://www.instagram.com/p/BIjAADPhUHZ/?taken-at=259197237:: target=::_blank:: rel=::noopener noreferrer::>@drock1987/Instagram</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Academy-from-scene.jpg" data-postname="academy-from-scene" data-width="966" data-height="1204" rel="9" title="&lt;h3&gt;&lt;a href=&quot;https://www.academytavern.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Academy Tavern&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;12800 Larchmere Blvd., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;Take pleasure in one of the Academy Tavern's many craft beers while indulging in their wonderful portions of breaded pike, coleslaw and fresh-cut fries. This Larchmere joint has been around for 83 years so we think they may know a thing or two about running a good bar/restaurant. 
&lt;br&gt;
&lt;br&gt;Photo via Scene Archives
" data-title="<span class='post-excerpt'><h3><a href=::https://www.academytavern.com:: target=::_blank:: rel=::noopener noreferrer::> Academy Tavern</a></h3>
<i>12800 Larchmere Blvd., Cleveland</i>
<br>
<br>Take pleasure in one of the Academy Tavern's many craft beers while indulging in their wonderful portions of breaded pike, coleslaw and fresh-cut fries. This Larchmere joint has been around for 83 years so we think they may know a thing or two about running a good bar/restaurant. 
<br>
<br>Photo via Scene Archives
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/flat-iron-cafe-from-scene.jpg" data-postname="flat-iron-cafe-from-scene" data-width="600" data-height="450" rel="10" title="&lt;h3&gt;&lt;a href=&quot;http://www.flatironcafe.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Flat Iron Café&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;1114 Center St., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;Serving Cleveland for over 100 years, this Irish pub is rich and full of history. Whether you’re a sailor, blacksmith or just a hungry customer, their Yellow Lake Erie Perch dinner is just what you need.
&lt;br&gt;
&lt;br&gt;Photo via Scene Archives
" data-title="<span class='post-excerpt'><h3><a href=::http://www.flatironcafe.com:: target=::_blank:: rel=::noopener noreferrer::>Flat Iron Café</a></h3>
<i>1114 Center St., Cleveland</i>
<br>
<br>Serving Cleveland for over 100 years, this Irish pub is rich and full of history. Whether you’re a sailor, blacksmith or just a hungry customer, their Yellow Lake Erie Perch dinner is just what you need.
<br>
<br>Photo via Scene Archives
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/rocky-river-brewing-company.jpg" data-postname="rocky-river-brewing-company" data-width="560" data-height="420" rel="11" title="&lt;h3&gt;&lt;a href=&quot;http://rockyriverbrewco.com/&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Rocky River Brewing Company&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt; 21290 Center Ridge Rd., Rocky River&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;Every Friday during Lent hit up the Rocky River Brewing Company for their fried cod with golden fries and creamy coleslaw. Pair it with one of their own craft beers like the Pirate Light Blond Ale. The quality is clean and the space is bigger than an NBA court. 
&lt;br&gt;
&lt;br&gt;Photo via Rocky River Brewing Company
" data-title="<span class='post-excerpt'><h3><a href=::http://rockyriverbrewco.com/:: target=::_blank:: rel=::noopener noreferrer::>Rocky River Brewing Company</a></h3>
<i> 21290 Center Ridge Rd., Rocky River</i>
<br>
<br>Every Friday during Lent hit up the Rocky River Brewing Company for their fried cod with golden fries and creamy coleslaw. Pair it with one of their own craft beers like the Pirate Light Blond Ale. The quality is clean and the space is bigger than an NBA court. 
<br>
<br>Photo via Rocky River Brewing Company
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Club-House-that-I-took.jpg" data-postname="club-house-that-i-took" data-width="1080" data-height="810" rel="12" title="&lt;h3&gt;Clubhouse&lt;/h3&gt;
&lt;i&gt;6365 Pearl Rd., Parma&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;This neighborhood dive bar offers a  daily fish fry featuring Lake Erie perch during Lent. But on Fridays they’ll give you more side options such as macaroni and cheese, fries and homefries. 
&lt;br&gt;
&lt;br&gt;Photo by Matt Poshedley&lt;/a&gt;
" data-title="<span class='post-excerpt'><h3>Clubhouse</h3>
<i>6365 Pearl Rd., Parma</i>
<br>
<br>This neighborhood dive bar offers a  daily fish fry featuring Lake Erie perch during Lent. But on Fridays they’ll give you more side options such as macaroni and cheese, fries and homefries. 
<br>
<br>Photo by Matt Poshedley</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/the-little-polish-diner.jpg" data-postname="the-little-polish-diner" data-width="600" data-height="450" rel="13" title="&lt;h3&gt;&lt;a href=&quot;https://www.facebook.com/Little-Polish-Diner-90023891360&quot;&gt; The Little Polish Diner&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;5772 Ridge Rd., Parma&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Known for its homestyle Polish cooking, The Little Polish Diner offers a traditional Perch fish fry every Friday throughout Lent. And in authentic Cleveland style, the potato side is pierogis instead of french fries if you want them. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.clevescene.com/cleveland/10-cleveland-fish-fries-worth-a-visit-this-season/Slideshow/3837461/3837470&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;The Little Polish Diner/Facebook&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::https://www.facebook.com/Little-Polish-Diner-90023891360::> The Little Polish Diner</a></h3>
<i>5772 Ridge Rd., Parma</i>
<br>
<br> Known for its homestyle Polish cooking, The Little Polish Diner offers a traditional Perch fish fry every Friday throughout Lent. And in authentic Cleveland style, the potato side is pierogis instead of french fries if you want them. 
<br>
<br>Photo via <a href=::https://www.clevescene.com/cleveland/10-cleveland-fish-fries-worth-a-visit-this-season/Slideshow/3837461/3837470:: target=::_blank:: rel=::noopener noreferrer::>The Little Polish Diner/Facebook</a></span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/1409149162-aroundthecorner_2_.jpg" data-postname="1409149162-aroundthecorner_2_" data-width="495" data-height="286" rel="14" title="&lt;h3&gt;&lt;a href=&quot;http://www.atccafe.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Around the Corner&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;18616-20 Detroit Ave., Lakewood&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Fish frys just feel right when they're at the bar around the corner. This Lakewood favorite, literally named Around the Corner, has events and specials for nearly every night of the week, but Fridays are for fish frys and homemade pierogis.
&lt;br&gt;
&lt;br&gt;Photo via Scene Archives" data-title="<span class='post-excerpt'><h3><a href=::http://www.atccafe.com:: target=::_blank:: rel=::noopener noreferrer::> Around the Corner</a></h3>
<i>18616-20 Detroit Ave., Lakewood</i>
<br>
<br> Fish frys just feel right when they're at the bar around the corner. This Lakewood favorite, literally named Around the Corner, has events and specials for nearly every night of the week, but Fridays are for fish frys and homemade pierogis.
<br>
<br>Photo via Scene Archives</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Gears-and-Cheers-From-their-Facebook-Page.jpg" data-postname="gears-and-cheers-from-their-facebook-page" data-width="960" data-height="720" rel="15" title="&lt;h3&gt;&lt;a href=&quot;http://www.segearsandcheers.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;South East Gears and Cheers&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt; 23333 Aurora Rd., Bedford Heights&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Take a loved one to this fish fry on a Friday after 5 p.m. This Bedford Heights spot is the place to be if you like a little rock 'n' roll with your fried fish. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/SouthEastGearsandCheers/photos/a.380735615314660.89493.380734978648057/457778297610391/?type=1&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Southeast Gears and Cheers/Facebook&lt;/a&gt;
" data-title="<span class='post-excerpt'><h3><a href=::http://www.segearsandcheers.com:: target=::_blank:: rel=::noopener noreferrer::>South East Gears and Cheers</a></h3>
<i> 23333 Aurora Rd., Bedford Heights</i>
<br>
<br> Take a loved one to this fish fry on a Friday after 5 p.m. This Bedford Heights spot is the place to be if you like a little rock 'n' roll with your fried fish. 
<br>
<br>Photo via <a href=::https://www.facebook.com/SouthEastGearsandCheers/photos/a.380735615314660.89493.380734978648057/457778297610391/?type=1&theater:: target=::_blank:: rel=::noopener noreferrer::>Southeast Gears and Cheers/Facebook</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="16" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/DiCillo-Tavern-Fish-Fry.jpg" data-postname="dicillo-tavern-fish-fry" data-width="960" data-height="640" rel="17" title="&lt;h3&gt;&lt;a href=&quot;http://www.dicillotavern.com/&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; DiCillo Tavern&lt;/a&gt;&lt;/h3&gt;
6088 Mayfield Rd., Mayfield Heights
&lt;br&gt;
&lt;br&gt; Consistency and originality is honored at DiCillo Tavern. Stop in to see their recent renovations and partake in their famous fish fry dinner, which they’ve been serving since 1933.  
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/DiCilloTavern/photos/a.383753871645318/1597890366898323/?type=1&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Di Cillo Tavern/Facebook&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::http://www.dicillotavern.com/:: target=::_blank:: rel=::noopener noreferrer::> DiCillo Tavern</a></h3>
6088 Mayfield Rd., Mayfield Heights
<br>
<br> Consistency and originality is honored at DiCillo Tavern. Stop in to see their recent renovations and partake in their famous fish fry dinner, which they’ve been serving since 1933.  
<br>
<br>Photo via <a href=::https://www.facebook.com/DiCilloTavern/photos/a.383753871645318/1597890366898323/?type=1&theater:: target=::_blank:: rel=::noopener noreferrer::>Di Cillo Tavern/Facebook</a></span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2018/02/Merwins.jpg" data-postname="merwins-3" data-width="1100" data-height="825" rel="18" title="&lt;h3&gt;&lt;a href=&quot;https://www.clevelandmetroparks.com/parks/visit/parks/lakefront-reservation/merwin-s-wharf&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Merwin’s Wharf&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;1785 Merwin Ave., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;Situated on Irishtown Bend, this waterfront restaurant, that's under the umbrella of the Cleveland Metro Parks, offers Instagram-ready views of the Cuyahoga River to go along with their popular perch fish fry.
&lt;br&gt;
&lt;br&gt;Photo via Scene Archives " data-title="<span class='post-excerpt'><h3><a href=::https://www.clevelandmetroparks.com/parks/visit/parks/lakefront-reservation/merwin-s-wharf:: target=::_blank:: rel=::noopener noreferrer::> Merwin’s Wharf</a></h3>
<i>1785 Merwin Ave., Cleveland</i>
<br>
<br>Situated on Irishtown Bend, this waterfront restaurant, that's under the umbrella of the Cleveland Metro Parks, offers Instagram-ready views of the Cuyahoga River to go along with their popular perch fish fry.
<br>
<br>Photo via Scene Archives </span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/Grumpys1.jpg" data-postname="grumpys1-3" data-width="1100" data-height="820" rel="19" title="&lt;h3&gt;&lt;a href=&quot;http://www.grumpys-cafe.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Grumpy’s Cafe&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;2621 West 14th St., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; A healthier option can be found at Grumpy Cafe’s “anti-fish fry,” which features breaded and grilled Haddock with herb roasted potatoes and slaw. The meal also include an option to add sauteed pierogis with grilled onions.
&lt;br&gt;
&lt;br&gt;Photo via Scene Archives" data-title="<span class='post-excerpt'><h3><a href=::http://www.grumpys-cafe.com:: target=::_blank:: rel=::noopener noreferrer::> Grumpy’s Cafe</a></h3>
<i>2621 West 14th St., Cleveland</i>
<br>
<br> A healthier option can be found at Grumpy Cafe’s “anti-fish fry,” which features breaded and grilled Haddock with herb roasted potatoes and slaw. The meal also include an option to add sauteed pierogis with grilled onions.
<br>
<br>Photo via Scene Archives</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/The-Harp.jpg" data-postname="the-harp-9" data-width="1100" data-height="618" rel="20" title="&lt;h3&gt;&lt;a href=&quot;http://www.the-harp.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; The Harp&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;4408 Detroit Ave., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;An Irish bar on steroids, the Harp isn’t just your corner joint with a few shamrocks on the wall. It boasts a large Irish-influenced menu and a spacious patio with a view of the lake. And with the Irish influence, they obviously know their fish and chips 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/TheHarpCLE/photos/a.447625376618/10153599661421619/?type=3&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;The Harp/Facebook&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::http://www.the-harp.com:: target=::_blank:: rel=::noopener noreferrer::> The Harp</a></h3>
<i>4408 Detroit Ave., Cleveland</i>
<br>
<br>An Irish bar on steroids, the Harp isn’t just your corner joint with a few shamrocks on the wall. It boasts a large Irish-influenced menu and a spacious patio with a view of the lake. And with the Irish influence, they obviously know their fish and chips 
<br>
<br>Photo via <a href=::https://www.facebook.com/TheHarpCLE/photos/a.447625376618/10153599661421619/?type=3&theater:: target=::_blank:: rel=::noopener noreferrer::>The Harp/Facebook</a></span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/Merry-Arts-Pub.jpg" data-postname="merry-arts-pub-8" data-width="1032" data-height="774" rel="21" title="&lt;h3&gt;&lt;a href=&quot;https://www.facebook.com/pages/Merry-Arts-Pub-Grill/115531568468319&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Merry Arts Pub and Grill&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;15607 Detroit Ave., Lakewood&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Fish frys are done right at Lakewood watering hole Merry Arts. They serve theirs for lunch and dinner every Friday during Lent from 11 a.m. to 11 p.m. with some of the best prices in town. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/photo.php?fbid=10200718840710341&amp;set=br.AbpWSjVZ8VdEEVDdHksos1g4RldKvUZDHwV__-ISE3hdLX5UMjvi22k1F1_Bw8Ww1yxqn28jaBRsE1eB8HI-s1cbEJbLkwTOdz-BXnCMCuOOLgS3C5X7epEiuLbr9yeuogHMcHMrvPIARa-F8y531LFksS6zIm8XbkqmpV4eiU_pAY_ryAkK0LRHpeiv9KIvwKAq2NlM4mdtxherQOWRrr60qLuKwEZN-f9zgY55Pjlb7NBs4uUxL8PaxwJNFLKGVNg&amp;type=3&amp;theater&quot;&gt;Merry Arts Pub and Grill/Facebook&lt;/a&gt;
" data-title="<span class='post-excerpt'><h3><a href=::https://www.facebook.com/pages/Merry-Arts-Pub-Grill/115531568468319:: target=::_blank:: rel=::noopener noreferrer::> Merry Arts Pub and Grill</a></h3>
<i>15607 Detroit Ave., Lakewood</i>
<br>
<br> Fish frys are done right at Lakewood watering hole Merry Arts. They serve theirs for lunch and dinner every Friday during Lent from 11 a.m. to 11 p.m. with some of the best prices in town. 
<br>
<br>Photo via <a href=::https://www.facebook.com/photo.php?fbid=10200718840710341&set=br.AbpWSjVZ8VdEEVDdHksos1g4RldKvUZDHwV__-ISE3hdLX5UMjvi22k1F1_Bw8Ww1yxqn28jaBRsE1eB8HI-s1cbEJbLkwTOdz-BXnCMCuOOLgS3C5X7epEiuLbr9yeuogHMcHMrvPIARa-F8y531LFksS6zIm8XbkqmpV4eiU_pAY_ryAkK0LRHpeiv9KIvwKAq2NlM4mdtxherQOWRrr60qLuKwEZN-f9zgY55Pjlb7NBs4uUxL8PaxwJNFLKGVNg&type=3&theater::>Merry Arts Pub and Grill/Facebook</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/Hansa.jpg" data-postname="hansa" data-width="1100" data-height="545" rel="22" title="&lt;h3&gt;&lt;a href=&quot;https://www.hansabrewery.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Hansa Brewery&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;2717 Lorain Ave., Cleveland&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; This Biergarten and beer hall is one of just a select few of German-style breweries in Cleveland. Breaded perch and grilled branzino are the Lent offerings here and they’re worth the trip to Ohio City. They’re one of the only places offering their fish fry during lunch, as they’ll be serving Fridays starting at 11:30 a.m. to 9 p.m. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/hansabrewery/photos/a.1676421605924526/1835521473347871/?type=3&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Hansa Brewery/Facebook&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::https://www.hansabrewery.com:: target=::_blank:: rel=::noopener noreferrer::> Hansa Brewery</a></h3>
<i>2717 Lorain Ave., Cleveland</i>
<br>
<br> This Biergarten and beer hall is one of just a select few of German-style breweries in Cleveland. Breaded perch and grilled branzino are the Lent offerings here and they’re worth the trip to Ohio City. They’re one of the only places offering their fish fry during lunch, as they’ll be serving Fridays starting at 11:30 a.m. to 9 p.m. 
<br>
<br>Photo via <a href=::https://www.facebook.com/hansabrewery/photos/a.1676421605924526/1835521473347871/?type=3&theater:: target=::_blank:: rel=::noopener noreferrer::>Hansa Brewery/Facebook</a></span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/Georgetown.jpg" data-postname="georgetown-3" data-width="960" data-height="720" rel="23" title="&lt;h3&gt;&lt;a href=&quot;http://www.georgetownrestaurant.net/&quot;&gt; Georgetown&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;18515 Detroit Ave., Lakewood&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Formerly Three Birds, Georgetown is another joint showing that you can be a little more upscale than the bars and restaurants that are typically known for doing Lenten fish frys. Every Friday during Lent from 4:30 p.m to 11 p.m., you can get a traditional Lenten dinner of fried panko-crusted grouper, with a side of fries, slaw and delicious cornbread. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/Georgetownrestaurant/photos/a.161554760656866.57237.146766992135643/839204606225208/?type=3&amp;theater&quot;&gt;Georgetown Restaurant Lakewood/Facebook&lt;/a&gt;
" data-title="<span class='post-excerpt'><h3><a href=::http://www.georgetownrestaurant.net/::> Georgetown</a></h3>
<i>18515 Detroit Ave., Lakewood</i>
<br>
<br> Formerly Three Birds, Georgetown is another joint showing that you can be a little more upscale than the bars and restaurants that are typically known for doing Lenten fish frys. Every Friday during Lent from 4:30 p.m to 11 p.m., you can get a traditional Lenten dinner of fried panko-crusted grouper, with a side of fries, slaw and delicious cornbread. 
<br>
<br>Photo via <a href=::https://www.facebook.com/Georgetownrestaurant/photos/a.161554760656866.57237.146766992135643/839204606225208/?type=3&theater::>Georgetown Restaurant Lakewood/Facebook</a>
</span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/Fishers-American-Tavern.jpg" data-postname="fishers-american-tavern" data-width="960" data-height="720" rel="24" title="&lt;h3&gt;&lt;a href=&quot;https://www.facebook.com/fishersamericantavern/&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; Fisher’s American Tavern&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;28020 Miles Rd., Solon&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Every Friday night, this Solon dive offers a wide variety of delicious fish. They have a beer-battered haddock basket with fries and slaw, a beer-battered walleye basket with the same sides and weekly specials like a shrimp basket and grilled walleye.
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/fishersamericantavern/photos/a.266391540588669/266391843921972/?type=1&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Fisher’s American Tavern/Facebook&lt;/a&gt;  " data-title="<span class='post-excerpt'><h3><a href=::https://www.facebook.com/fishersamericantavern/:: target=::_blank:: rel=::noopener noreferrer::> Fisher’s American Tavern</a></h3>
<i>28020 Miles Rd., Solon</i>
<br>
<br> Every Friday night, this Solon dive offers a wide variety of delicious fish. They have a beer-battered haddock basket with fries and slaw, a beer-battered walleye basket with the same sides and weekly specials like a shrimp basket and grilled walleye.
<br>Photo via <a href=::https://www.facebook.com/fishersamericantavern/photos/a.266391540588669/266391843921972/?type=1&theater:: target=::_blank:: rel=::noopener noreferrer::>Fisher’s American Tavern/Facebook</a>  </span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/Carnicero.jpg" data-postname="carnicero-2" data-width="1080" data-height="810" rel="25" title="&lt;h3&gt;&lt;a href=&quot;http://elcarnicerolakewood.com/&quot;&gt; El Carnicero&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;16918 Detroit Rd., Lakewood&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; Chef Eric Williams, of Momocho and Happy Dog, opened this Mexican joint back in 2013 to expand on the Mexican taste that he mastered at Momocho. And when a great Mexican spot offers up a fish frys, ,we’re automatically in. The Lake Erie perch is served Fridays during Lent from 4 p.m. to 8 p.m. and is beer-battered in Dos Equis, naturally, and served with a chipotle tartar sauce with potato wedges and delicious cornmeal jalapeño hushpuppies. 
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.instagram.com/p/BXY6YnIAXxX/?taken-at=115342950&quot;&gt;@Memowery/Instagram&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::http://elcarnicerolakewood.com/::> El Carnicero</a></h3>
<i>16918 Detroit Rd., Lakewood</i>
<br>
<br> Chef Eric Williams, of Momocho and Happy Dog, opened this Mexican joint back in 2013 to expand on the Mexican taste that he mastered at Momocho. And when a great Mexican spot offers up a fish frys, ,we’re automatically in. The Lake Erie perch is served Fridays during Lent from 4 p.m. to 8 p.m. and is beer-battered in Dos Equis, naturally, and served with a chipotle tartar sauce with potato wedges and delicious cornmeal jalapeño hushpuppies. 
<br>
<br>Photo via <a href=::https://www.instagram.com/p/BXY6YnIAXxX/?taken-at=115342950::>@Memowery/Instagram</a></span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-postname="" data-width="300" data-height="250" rel="26" title=" " data-title=" " itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2019/03/Thyme.jpg" data-postname="thyme" data-width="1100" data-height="730" rel="27" title="&lt;h3&gt;&lt;a href=&quot;http://www.thymetherestaurant.com&quot;target=&quot;_blank&quot;&gt; Thyme2&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;113 West Smith St., Medina&lt;/i&gt;
&lt;br&gt;
&lt;br&gt; The successor to chef-owner John Kolar's Thyme, Thyme2 offers two distinct environments: fine dining upstairs and a pub below. And while this might be a little more upscale than most joints participating in Lenten, don’t let the nicer atmosphere throw you off. Because their fish frys, every Friday from 4 p.m. to 9:30 p.m. during Lent, are phenomenal. For $18 you get an orange roughy fish dinner that’s beer-battered with Thirsty Dog’s Labrador Lager.
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/thyme2restaurantmedina/photos/p.2580739078609579/2580739078609579/?type=1&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Thyme Restaurant/Facebook&lt;/a&gt;  " data-title="<span class='post-excerpt'><h3><a href=::http://www.thymetherestaurant.com::target=::_blank::> Thyme2</a></h3>
<i>113 West Smith St., Medina</i>
<br>
<br> The successor to chef-owner John Kolar's Thyme, Thyme2 offers two distinct environments: fine dining upstairs and a pub below. And while this might be a little more upscale than most joints participating in Lenten, don’t let the nicer atmosphere throw you off. Because their fish frys, every Friday from 4 p.m. to 9:30 p.m. during Lent, are phenomenal. For $18 you get an orange roughy fish dinner that’s beer-battered with Thirsty Dog’s Labrador Lager.
<br>
<br>Photo via <a href=::https://www.facebook.com/thyme2restaurantmedina/photos/p.2580739078609579/2580739078609579/?type=1&theater:: target=::_blank:: rel=::noopener noreferrer::>Thyme Restaurant/Facebook</a>  </span>" itemprop="image" /><img class='post-image' style="display: none" src="https://photos.clevescene.com/wp-content/plugins/photo-slider-new/images/blank.gif" data-url="https://photos.clevescene.com/wp-content/uploads/2020/02/FireHouse.jpg" data-postname="firehouse" data-width="475" data-height="369" rel="28" title="&lt;h3&gt;&lt;a href=&quot;http://www.firehousegrilleandpub.com&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt; FireHouse Grill and Pub&lt;/a&gt;&lt;/h3&gt;
&lt;i&gt;2768 Stark Dr., Willoughby&lt;/i&gt;
&lt;br&gt;
&lt;br&gt;Out in Willoughby, this pub and grill doesn’t mess around when it comes to their fish fry. For $14, you get all-you-can-eat tender Icelandic cod - battered or broiled and its served with fries and homemade coleslaw.
&lt;br&gt;
&lt;br&gt;Photo via &lt;a href=&quot;https://www.facebook.com/firehousegrilleandpub/photos/a.396290307052788/3405570012791454/?type=3&amp;theater&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Firehouse Grill and Pub/Facebook&lt;/a&gt;" data-title="<span class='post-excerpt'><h3><a href=::http://www.firehousegrilleandpub.com:: target=::_blank:: rel=::noopener noreferrer::> FireHouse Grill and Pub</a></h3>
<i>2768 Stark Dr., Willoughby</i>
<br>
<br>Out in Willoughby, this pub and grill doesn’t mess around when it comes to their fish fry. For $14, you get all-you-can-eat tender Icelandic cod - battered or broiled and its served with fries and homemade coleslaw.
<br>
<br>Photo via <a href=::https://www.facebook.com/firehousegrilleandpub/photos/a.396290307052788/3405570012791454/?type=3&theater:: target=::_blank:: rel=::noopener noreferrer::>Firehouse Grill and Pub/Facebook</a></span>" itemprop="image" /> </div>
<div id="slide-caption"></div>
<div class="description">
<p>Over the years, many Cleveland restaurants, taverns and pubs have kept their Lenten fish fry traditions afloat, some have even started their own tasty traditions. And with these 25 spots, you'll find just the fish and atmosphere you're looking for this season.</p>
</div>


<div id="fb-comments"></div>

<input type="hidden" id="photo-count" value="28" />
<input type="hidden" id="page-url-1" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=1&screen-shot-2018-02-09-at-2-05-21-pm" /><input type="hidden" id="image-url-1" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/screen-shot-2018-02-09-at-2-05-21-pm/" /><input type="hidden" id="page-url-2" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=2&prosperity-4" /><input type="hidden" id="image-url-2" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/prosperity-4/" /><input type="hidden" id="page-url-3" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=3&screen-shot-2018-02-09-at-2-34-34-pm" /><input type="hidden" id="image-url-3" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/screen-shot-2018-02-09-at-2-34-34-pm/" /><input type="hidden" id="page-url-4" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=4&screen-shot-2018-02-12-at-1-12-17-pm" /><input type="hidden" id="image-url-4" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/screen-shot-2018-02-12-at-1-12-17-pm/" /><input type="hidden" id="page-url-5" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=5&lake-house-restaurant-pic-from-their-facebook" /><input type="hidden" id="image-url-5" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/lake-house-restaurant-pic-from-their-facebook/" /><input type="hidden" id="page-url-6" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=6" /><input type="hidden" id="image-url-6" value="" /><input type="hidden" id="page-url-7" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=7&tick-tock-from-facebook" /><input type="hidden" id="image-url-7" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/tick-tock-from-facebook/" /><input type="hidden" id="page-url-8" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=8&screen-shot-2018-02-09-at-3-03-33-pm" /><input type="hidden" id="image-url-8" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/screen-shot-2018-02-09-at-3-03-33-pm/" /><input type="hidden" id="page-url-9" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=9&academy-from-scene" /><input type="hidden" id="image-url-9" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/academy-from-scene/" /><input type="hidden" id="page-url-10" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=10&flat-iron-cafe-from-scene" /><input type="hidden" id="image-url-10" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/flat-iron-cafe-from-scene/" /><input type="hidden" id="page-url-11" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=11&rocky-river-brewing-company" /><input type="hidden" id="image-url-11" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/rocky-river-brewing-company/" /><input type="hidden" id="page-url-12" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=12&club-house-that-i-took" /><input type="hidden" id="image-url-12" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/club-house-that-i-took/" /><input type="hidden" id="page-url-13" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=13&the-little-polish-diner" /><input type="hidden" id="image-url-13" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/the-little-polish-diner/" /><input type="hidden" id="page-url-14" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=14&1409149162-aroundthecorner_2_" /><input type="hidden" id="image-url-14" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/1409149162-aroundthecorner_2_/" /><input type="hidden" id="page-url-15" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=15&gears-and-cheers-from-their-facebook-page" /><input type="hidden" id="image-url-15" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/gears-and-cheers-from-their-facebook-page/" /><input type="hidden" id="page-url-16" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=16" /><input type="hidden" id="image-url-16" value="" /><input type="hidden" id="page-url-17" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=17&dicillo-tavern-fish-fry" /><input type="hidden" id="image-url-17" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/dicillo-tavern-fish-fry/" /><input type="hidden" id="page-url-18" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=18&merwins-3" /><input type="hidden" id="image-url-18" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/merwins-3/" /><input type="hidden" id="page-url-19" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=19&grumpys1-3" /><input type="hidden" id="image-url-19" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/grumpys1-3/" /><input type="hidden" id="page-url-20" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=20&the-harp-9" /><input type="hidden" id="image-url-20" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/the-harp-9/" /><input type="hidden" id="page-url-21" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=21&merry-arts-pub-8" /><input type="hidden" id="image-url-21" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/merry-arts-pub-8/" /><input type="hidden" id="page-url-22" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=22&hansa" /><input type="hidden" id="image-url-22" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/hansa/" /><input type="hidden" id="page-url-23" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=23&georgetown-3" /><input type="hidden" id="image-url-23" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/georgetown-3/" /><input type="hidden" id="page-url-24" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=24&fishers-american-tavern" /><input type="hidden" id="image-url-24" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/fishers-american-tavern/" /><input type="hidden" id="page-url-25" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=25&carnicero-2" /><input type="hidden" id="image-url-25" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/carnicero-2/" /><input type="hidden" id="page-url-26" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=26" /><input type="hidden" id="image-url-26" value="" /><input type="hidden" id="page-url-27" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=27&thyme" /><input type="hidden" id="image-url-27" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/thyme/" /><input type="hidden" id="page-url-28" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/?slide=28&firehouse" /><input type="hidden" id="image-url-28" value="https://photos.clevescene.com/20-cleveland-fish-fries-need-try-lenten-season/firehouse/" /> </div>
<div class="other-sliders">
<h2 class="viewmore" itemprop="headline">View these other slideshows:</h2>
<div class="gallery-item">
<a href="https://photos.clevescene.com/15-fun-things-to-do-this-week-in-cleveland-feb-26-march-3/?utm_source=widget&utm_medium=slideshows&utm_campaign=endofarticle&utm_content=slideshowend" title="See 15 Fun Things to Do This Week in Cleveland (Feb. 26-March 3)"><img width="300" height="250" src="https://photos.clevescene.com/wp-content/uploads/2018/06/Mac-Archives-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>15 Fun Things to Do This Week in Cleveland (Feb. 26-March 3)</h2></a>
</div>
<div class="gallery-item">
<a href="https://photos.clevescene.com/15-bakeries-to-get-your-paczki-fix-on-fat-tuesday/?utm_source=widget&utm_medium=slideshows&utm_campaign=endofarticle&utm_content=slideshowend" title="See 20 Cleveland Bakeries to Get Your Paczki Fix on Fat Tuesday"><img width="300" height="250" src="https://photos.clevescene.com/wp-content/uploads/2019/03/Michael-Angelos-Paczki-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>20 Cleveland Bakeries to Get Your Paczki Fix on Fat Tuesday</h2></a>
</div>
<div class="gallery-item">
<a href="https://photos.clevescene.com/photos-from-the-martin-luther-king-jr-achievement-awards-mixer-at-lotus/?utm_source=widget&utm_medium=slideshows&utm_campaign=endofarticle&utm_content=slideshowend" title="See Photos From the Martin Luther King Jr. Achievement Awards Mixer at Lotus"><img width="300" height="250" src="https://photos.clevescene.com/wp-content/uploads/2020/02/ENP-9732-Copy-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>Photos From the Martin Luther King Jr. Achievement Awards Mixer at Lotus</h2></a>
</div>
<div class="gallery-item">
<a href="https://photos.clevescene.com/all-the-sweet-tats-we-saw-at-the-2020-cleveland-tattoo-arts-convention/?utm_source=widget&utm_medium=slideshows&utm_campaign=endofarticle&utm_content=slideshowend" title="See All the Sweet Tats We Saw at the 2020 Cleveland Tattoo Arts Convention"><img width="300" height="250" src="https://photos.clevescene.com/wp-content/uploads/2020/02/ENP-0373-300x250.jpg" class="attachment-gallery-featured-home size-gallery-featured-home wp-post-image" alt="" /> <h2>All the Sweet Tats We Saw at the 2020 Cleveland Tattoo Arts Convention</h2></a>
</div>
<div class="back-to-slider">&laquo; View the previous slideshow again!</div>
</div>
</main>
<footer class="article-footer">
<div id="div-gpt-ad-cle_728x90-2" class="bottomLeaderboard"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_728x90-2'); });</script></div>

<div id="div-gpt-ad-cle_desktopnative-3"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_desktopnative-3'); });</script></div>
<p class="meta">Posted <time datetime="2019-03-6" pubdate>Mar. 6, 2019</time>
<span class="amp">&</span> filed under <a href="https://photos.clevescene.com/category/foodslideshows/" rel="category tag">Food and Drink</a>.
</p>
<div id="crumbs"><a href="https://photos.clevescene.com">Home</a> &raquo; <a href="https://photos.clevescene.com/category/foodslideshows/">Food and Drink</a> &raquo; <span class="current">25 Cleveland Fish Fries You Need To Try This Lenten Season</span></div>
<p class="tags"><span class="tags-title">Tags:</span> <a href="https://photos.clevescene.com/tag/cleveland-fish-fry/" rel="tag">Cleveland Fish Fry</a>, <a href="https://photos.clevescene.com/tag/fish-fry/" rel="tag">Fish Fry</a>, <a href="https://photos.clevescene.com/tag/lent/" rel="tag">Lent</a></p>
</footer> 
</div>
<div class="col-md-4" id="sidebar-right">
<div class="medRectangle">
<div id="div-gpt-ad-cle_300x250-1"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_300x250-1'); });</script></div> </div>
<div class="gallery-teasers">
<h2 class="sectionheader">Browse Galleries</h2>
<div id="tS3" class="jThumbnailScroller">
<div class="jTscrollerContainer">
<div class="jTscroller">
<a href="https://photos.clevescene.com/15-fun-things-to-do-this-week-in-cleveland-feb-26-march-3/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.clevescene.com/wp-content/uploads/2018/06/Mac-Archives-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>15 Fun Things to Do This Week in Cleveland (Feb. 26-March 3)</p><a href="https://photos.clevescene.com/15-bakeries-to-get-your-paczki-fix-on-fat-tuesday/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.clevescene.com/wp-content/uploads/2019/03/Michael-Angelos-Paczki-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>20 Cleveland Bakeries to Get Your Paczki Fix on Fat Tuesday</p><a href="https://photos.clevescene.com/photos-from-the-martin-luther-king-jr-achievement-awards-mixer-at-lotus/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.clevescene.com/wp-content/uploads/2020/02/ENP-9732-Copy-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>Photos From the Martin Luther King Jr. Achievement Awards Mixer at Lotus</p><a href="https://photos.clevescene.com/all-the-sweet-tats-we-saw-at-the-2020-cleveland-tattoo-arts-convention/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.clevescene.com/wp-content/uploads/2020/02/ENP-0373-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>All the Sweet Tats We Saw at the 2020 Cleveland Tattoo Arts Convention</p><a href="https://photos.clevescene.com/wild-photos-from-the-2020-flats-east-bank-mardi-gras-bar-crawl/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.clevescene.com/wp-content/uploads/2020/02/ENP-9922-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>Wild Photos From the 2020 Flats East Bank Mardi Gras Bar Crawl</p><a href="https://photos.clevescene.com/everything-we-saw-at-brite-winter-fest-2020/?utm_source=widget&utm_medium=slideshows&utm_campaign=rightrail&utm_content=browsegalleries" target="_top"><img width="280" height="120" src="https://photos.clevescene.com/wp-content/uploads/2020/02/ENP-0069-280x120.jpg" class="attachment-gallery-featured-panorama size-gallery-featured-panorama wp-post-image" alt="" /></a><p>Everything We Saw at Brite Winter Fest 2020</p> </div>
</div>
<a href="#" class="jTscrollerPrevButton"></a>
<a href="#" class="jTscrollerNextButton"></a>
</div>
</div>
<div class="medRectangle">
<div id="div-gpt-ad-cle_300x250-2"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_300x250-2'); });</script></div> </div>
</div>
<script>
	/* jQuery.noConflict() for using the plugin along with other libraries.
	 You can remove it if you won't use other libraries (e.g. prototype, scriptaculous etc.) or
	 if you include jQuery before other libraries in yourdocument's head tag.
	 [more info: http://docs.jquery.com/Using_jQuery_with_Other_Libraries] */
	jQuery.noConflict();
	/* calling thumbnailScroller function with options as parameters */
	(function ( $ ) {
		window.onload = function () {
			$( "#tS3" ).thumbnailScroller( {
				scrollerType: "clickButtons",
				scrollerOrientation: "vertical",
				scrollSpeed: 2,
				scrollEasing: "easeOutCirc",
				scrollEasingAmount: 800,
				acceleration: 4,
				scrollSpeed: 800,
				noScrollCenterSpace: 10,
				autoScrolling: 0,
				autoScrollingSpeed: 2000,
				autoScrollingEasing: "easeInOutQuad",
				autoScrollingDelay: 500
			} );
		}
	})( jQuery );
</script>

</div>
</div>
<footer id="siteFooter" role="contentinfo">

<div id="FooterInfo" class="GlobalFooter FreeStuffLanding ">
<div class="footerCustomInfo col-md-4">
<h2>Cleveland Scene</h2>
<p>737 Bolivar Rd.</p>
<p>Suite 4100</p>
<p>Cleveland, OH 44115</p>
<p>Phone: (216) 241-7550</p>
<p>Classified Phone: (216) 802-7229</p>
<p>Fax: (216) 241-6275</p>
</div>
<div class="footerCustomWrap col-md-8">
<div class="footerCustomNav">
<ul>
<li><a target="_top" href="http://www.clevescene.com/cleveland/Contact/Page">Contact</a></li>
<li><a target="_top" href="http://www.clevescene.com/cleveland/AdvertisingInfo/Page">Advertise</a>
</li>
<li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
<li><a target="_top" href="http://www.clevescene.com/cleveland/Jobs/Page">Work Here</a></li>
</ul>
<p>All parts of this site Copyright &copy; 2020 Cleveland Scene.</p>
</div>
</div>
<div class="clear"></div>
</div>

<div id="FooterNavigation" class="GlobalFooter Home ">
<div class="linkGroupColumn">
<div class="linkGroup">
<h3>
<a href="http://www.clevescene.com/cleveland/news/Section?oid=1392923" target="_self">
News
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.clevescene.com/cleveland/news/Section?oid=1392923" target="_self">News
Home</a></li>
<li><a href="http://www.clevescene.com/cleveland/news-features/Category?oid=1518227" target="_self">Features</a></li>
<li><a href="http://www.clevescene.com/cleveland/cover-story/Content?special=1521546" target="_self">Cover Story</a></li>
<li><a href="http://www.clevescene.com/blogs/scene-and-heard/" target="_self">Scene & Heard:
Scene's News Blog</a></li>
<li><a href="http://npaper-wehaa.com/clevescene" target="_blank">Issue Flipbooks</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.clevescene.com/cleveland/music/Section?oid=1392924" target="_self">
Music
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.clevescene.com/cleveland/music/Section?oid=1392924" target="_self">Music
Home</a></li>
<li><a href="http://www.clevescene.com/cleveland/music-feature/Category?oid=1518237" target="_self">Features</a></li>
<li><a href="http://www.clevescene.com/cleveland/music-lead/Content?category=1518228" target="_self">Music Lead</a></li>
<li><a href="http://www.clevescene.com/cleveland/discourse-reviews/Category?oid=1518232" target="_self">CD Reviews</a></li>
<li><a href="http://www.clevescene.com/cleveland/band-of-the-week/Content?category=1518236" target="_self">Band of the Week</a></li>
<li><a href="http://clevescene.getn2.it/" target="_blank">Concert Listings</a></li>
<li><a href="http://www.clevescene.com/cleveland/EventSearch?feature=Club&eventSection=1471254" target="_self">Club Listings</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/museums/LocationSearch?locationCategory=1430792" target="_self">Music Venues</a></li>
<li><a href="http://clevescene.getn2.it/form/userSubmit?type=event" target="_blank">Submit a
Concert Listing</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.clevescene.com/cleveland/film/Section?oid=1392922" target="_self">
Movies
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.clevescene.com/cleveland/film/Section?oid=1392922" target="_self">Film
Home Page</a></li>
<li><a href="http://www.clevescene.com/cleveland/film-lead/Content?category=1518224" target="_self">Film Lead</a></li>
<li><a href="http://www.clevescene.com/cleveland/film-features/Content?category=1518238" target="_self">Features</a></li>
<li><a href="http://www.clevescene.com/cleveland/LocationSearch?locationCategory=1430798" target="_self">Movie Theaters</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.clevescene.com/cleveland/dining/Section?oid=1392921" target="_self">
Eat
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.clevescene.com/cleveland/drink-up/Category?oid=2703757" target="_self">Drink
Up</a></li>
<li><a href="http://www.clevescene.com/cleveland/dining/Section?oid=1392921" target="_self">Dining
Home Page</a></li>
<li><a href="http://www.clevescene.com/cleveland/dining-lead/Content?category=1518226" target="_self">Dining Review</a></li>
<li><a href="http://www.clevescene.com/cleveland/food-features/Category?oid=1520384" target="_self">Food Features</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/patio-guide-spice-kitchen-bar/Content?oid=4341400" target="_self">Patio Spotlight</a></li>
<li><a href="http://www.clevescene.com/cleveland/drink-features/Content?category=3206404" target="_self">Drink Features</a></li>
<li><a href="http://happyhours.clevescene.com/cleveland/find/places" target="_self">Happy Hour
Guide</a></li>
<li><a href="http://www.clevescene.com/cleveland/LocationSearch?locationSection=1435342" target="_self">Dining Guide</a></li>
<li><a href="http://www.clevescene.com/cleveland/LocationSearch?feature=Menu" target="_self">Restaurant
Menus</a></li>
<li><a href="http://www.clevescene.com/cleveland/LocationSearch?locationCategory=1430791" target="_self">Wineries/Breweries</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.clevescene.com/cleveland/arts/Section?oid=1392919" target="_self">
Arts
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.clevescene.com/cleveland/arts/Section?oid=1392919" target="_self">Arts
Home Page</a></li>
<li><a href="http://www.clevescene.com/cleveland/theater/Category?oid=1518230" target="_self">Theater
Reviews</a></li>
<li><a href="http://www.clevescene.com/cleveland/visual-art/Category?oid=1518229" target="_self">Art Reviews</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/galleries/LocationSearch?locationCategory=1528779" target="_self">Galleries</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/museums/LocationSearch?locationCategory=1528780" target="_self">Museums</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/theaters/LocationSearch?locationCategory=1528781" target="_self">Theraters</a></li>
<li><a href="http://www.clevescene.com/cleveland/LocationSearch?locationCategory=1430795" target="_self">Other Arts Venues</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://www.clevescene.com/cleveland/EventSearch?narrowByDate=Today&eventSection=1173452" target="_self">
Get Out
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.clevescene.com/general/pdfs/trailsofterror.PDF" target="_blank">Trails
of Terror</a></li>
<li><a href="http://www.clevescene.com/cleveland/EventSearch" target="_self">Events Home
Page</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/EventSearch?narrowByDate=Today&eventSection=1173452" target="_self">Event Calendar</a></li>
<li><a href="http://clevescene.getn2.it/" target="_blank">Concert Listings</a></li>
 <li><a href="http://www.clevescene.com/cleveland/Events/AddEvent" target="_self">Submit an
Event</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://www.clevescene.com/cleveland/special-sections/Section?oid=1518239" target="_self">
Special Sections
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://www.clevescene.com/cleveland/welcome-to-city-guide/Content?oid=4491140" target="_self">City Guide</a></li>
<li><a href="http://bestof.clevescene.com/l/Best-of-Cleveland-2015" target="_self">Best of
Cleveland VOTE NOW!</a></li>
<li><a href="http://www.clevescene.com/cleveland/the-2014-comedy-issue/Content?oid=4420815" target="_self">Comedy Issue 2014</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/winter-guide-2014-the-best-of-the-holiday-season/Content?oid=4432468" target="_self">Winter Guide 2014</a></li>
<li><a href="http://www.clevescene.com/cleveland/flavor-2014/Content?oid=4412403" target="_self">Flavor 2014</a></li>
<li><a href="http://www.clevescene.com/cleveland/the-fiction-issue/Content?oid=4484951" target="_self">The Fiction Issue</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/cleveland-fall-arts-guide-2014/Content?oid=4383093" target="_self">Fall Arts Guide 2014</a></li>
<li><a href="http://www.clevescene.com/cleveland/college-guide-2014/Content?oid=4358677" target="_self">College Guide</a></li>
<li><a href="http://www.clevescene.com/cleveland/the-gay-games-issue/Content?oid=4351110" target="_self">Gay Games</a></li>
<li><a href="http://www.clevescene.com/cleveland/summer-guide-2014/Content?oid=4327922" target="_self">Summer Guide 2014</a></li>
<li><a href="http://www.clevescene.com/cleveland/cleveland-people/Category?oid=3631702" target="_self">People Issue</a></li>
<li>
<a href="http://www.clevescene.com/cleveland/the-big-book-of-cleveland-2011/Content?oid=2622582" target="_self">The Big Book of Cleveland</a></li>
<li><a href="http://www.clevescene.com/cleveland/best-of-cleveland-2014/BestOf?oid=4297964" target="_self">Best of Cleveland 2014</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="http://cleveland.backpage.com/online/classifieds/index" target="_self">
Classifieds
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://cleveland.backpage.com/online/classifieds/index" target="_blank">Classifieds
Search</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="http://cleveland.backpage.com/personals/classifieds/Disclaimer?section=4383" target="_blank">
Personals
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="http://cleveland.backpage.com/personals/classifieds/Disclaimer?section=4383" target="_blank">Personals Search</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Social Media</h3>
<ul class="sublinkGroup">
<li><a href="http://www.facebook.com/ClevelandScene" target="_blank">Facebook</a></li>
<li><a href="http://twitter.com/Cleveland_Scene" target="_blank">Twitter</a></li>
<li><a href="http://statigr.am/clevescene" target="_blank">Instagram</a></li>
<li><a href="https://plus.google.com/108630931754112472513" target="_blank">Google Plus</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>About CleveScene</h3>
<ul class="sublinkGroup">
<li><a href="https://www.clevescene.com/cleveland/Policies/Page" target="_self">Policies</a></li>
<li><a href="http://www.clevescene.com/general/pdfs/2015-PrintMediaKit.pdf" target="_blank">Media
Kit</a></li>
<li><a href="http://www.clevescene.com/cleveland/AdvertisingInfo/Page" target="_self">Advertising
Info</a></li>
<li><a href="http://www.clevescene.com/cleveland/Contact/Page" target="_self">Contact</a></li>
<li><a href="http://www.clevescene.com/cleveland/Jobs/Page" target="_self">Jobs</a></li>
</ul>
</div>
</div>
</div>

</footer>
</div>

<script type="text/javascript" async=true>
    var __cmp = (function () {
      return typeof (__cmp) == "function" ? __cmp : function (c) {
        var b = arguments;
        if (!b.length) {
          return __cmp.a;
        }
        else if (c == '__cmp')
          return false;
        else {
          if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
          }
          __cmp.a.push([].slice.apply(b));
        }
      }
    })();
    var elem = document.createElement('script');
    elem.src = "https://quantcast.mgr.consensu.org/cmp.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);

    window.__cmp('init', {
  		'Language': 'en',
		'Initial Screen Reject Button Text': 'I do not accept',
		'Initial Screen Accept Button Text': 'I accept',
		'Purpose Screen Header Title Text': 'Privacy settings',
		'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
		'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
		'Vendor Screen Accept All Button Text': 'Accept all',
		'Vendor Screen Reject All Button Text': 'Reject all',
		'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
		'Initial Screen Body Text Option': 1,
		'Publisher Name': 'Cleveland Scene',
		'Publisher Purpose IDs': [1,2,5,4,3],
		'Post Consent Page': 'https://www.clevescene.com/cleveland/Policies/Page',
    });
  </script>


<link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.css" />
<script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.js"></script>
<script>

            window.addEventListener("load", function(){
        window.cookieconsent.initialise({
          "palette": {
            "popup": {
              "background": "#000000",
              "text": "#ffffff"
            },
            "button": {
              "background": "#D91F34",
              "text": "#ffffff"
            }
          },
          "position": "top",
          "content": {
            "message": "We use cookies to understand how you use our site and to improve your experience. By continuing to use our site, you accept our use of cookies, revised Privacy Policy and Terms.",
            "href": "https://www.clevescene.com/cleveland/Policies/Page"
          }
        })});
    </script><script type='text/javascript' src='https://photos.clevescene.com/wp-content/plugins/wpsocialite/Socialite/socialite.min.js?ver=2.0'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/plugins/wpsocialite/wpsocialite.js?ver=1.0'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/plugins/wpsocialite/Socialite/extensions/socialite.pinterest.js?ver=1.0'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/js/vendor/bootstrap.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/js/main.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/themes/euclid-slideshows-new/js/jquery.thumbnailScroller.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/plugins/photo-slider-new/js/photo-slider.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-content/plugins/photo-slider-new/js/jquery.touchSwipe.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://photos.clevescene.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type="text/javascript">Socialite.setup({facebook:{lang:'en_US',appId:null},twitter:{lang:'en'},googleplus:{lang:'en'},vkontakte:{apiId:''}});</script>

<div id="div-gpt-ad-cle_desktopinterstitial"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_desktopinterstitial'); });</script></div>
</body>
</html> 